JobGrok Listing - V3.1-1.2.58 (and prior was vulnerable) - com_jobgroklist
Resolution: update to V3.1-1.2.59
 
JobGrok Application - V3.1-1.2.55 (and prior was vulnerable) - com_jobgrokapp
Resolution: update to V3.1-1.2.56
 
JobGrok Premium - V3.1-1.6.69 (and prior was vulnerable) - com_jobgrok
Resolution: update to V3.1-1.6.70

Update Notice: http://www.tk-tek.com/security-fix-2017-04-03

.